Archive for the ‘Lenovo SL500’ Category

Lenovo SL500 continuous noisy loud fan after booting

Sunday, January 18th, 2009

I have just updated my Lenovo SL500 bios which ship with 1.07 bios version to the latest flash available on Lenovo support website that is v1.18. The update was smooth and the good news is I can switch off the Bluetooth by using Fn+F5 and it will keep the state when you reboot your laptop. It also keep the state of your screen brightness the next time you reboot in Windows XP. However, I didn’t realize that I have created big mess with the fan until recently.

I guess there is a bug on this new bios version relating to your fan speed control. The symptoms are if you have bios version 1.18 and you plug out the battery, few seconds after booting your laptop fan will go berserk creating high level of noise and air flow on the side of your laptop. By the way, when I use the battery with or without the main A/C adapter, it runs smoothly.

Well this is real bad situation for me, as I love to plug out my battery when I am not using it to prolong its life. Secondly, the fan noise is so disturbing so that you are barely can enjoy listening your music or watching movies.

What can we learn from this? Do not update if you live happily with your current system and do not need those extra feature which you can get from the new version. There are also some applications out there that I am aware of to control your laptop fan speed, but I strongly suggest to downgrade your bios to v1.16. Bios v1.14 and v1.16 are free from this loud fan bug. You can download this bios from lenovo support website and please select bootable cd method (it’s quicker and saver). Last word, Lenovo as a durable and business standard laptop provider should have published bug free drivers and software.